2017-11-14

Attention all Firefox users

Firefox 57 shipped to release on November 14, 2017 and no longer supports older browser extensions. To use Firefox 57 with Citavi, please update to Citavi 5.6 or 5.7 and the latest version of the Picker from the Firefox Add-on store.

Please see our FAQ for more information.

Wichtige Info zu Firefox 57

Am 14.11.2017 wurde Firefox 57 veröffentlicht. Diese Version unterstützt ältere Browser-Erweiterungen nicht mehr. Um Firefox 57 zusammen mit Citavi zu verwenden, brauchen Sie die aktuelle Picker-Version aus dem Firefox-Store und Citavi 5.6 oder 5.7.

Lesen Sie bitte unseren FAQ-Artikel.

2017-11-13

Citavi 6 Beta 6 Released

This new Beta fixes several bugs and makes various smaller improvements. Again, we'd like to send out a big thank you to our beta testers.

We love hearing from you! Your feedback keeps us moving forward!

Citavi 6 Beta 6 veröffentlicht

Wir haben nachgelegt: Mit der sechsten Beta-Version von Citavi 6 konnten wir mehrere Bugs beheben, die von Ihnen gemeldet wurden.

Wir freuen uns auf Ihr Feedback.